解决Adobe Reader不能启动(发生 Expr: 写入时发生错误)

AdobeReader不启动,在终端运行,提示:
expr: 写入时发生错误
……

应该时GTK版本号导致的。
修改/usr/bin/acroread
找到行:
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

这句里面'.\([0-9]\)00.'部分只能处理000-900,
[username ~]$ locate libgtk-x11
/usr/lib/libgtk-x11-2.0.so.0.1200.0
/usr/lib/libgtk-x11-2.0.so
/usr/lib/libgtk- x11-2.0.la
/usr/lib/libgtk-x11-2.0.a
/usr/lib/libgtk-x11-2.0.so.0

我的是libgtk-x11-2.0.so.0.1200.2,改成
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\) \([0-9]\)00*.\([0-9]*\)\|\(.*\)/\1\2\3/g'


Comments